PHP, which is a recursive initialism for PHP: Hypertext Preprocessor, is amongst the most commonly used general-purpose scripting languages out there. Any site or application created with PHP will run on a given web server provided that a PHP module is enabled, which renders the language really universal and it comes as no surprise that there are actually several million servers that support it and hundreds of millions of PHP websites hosted on them. PHP is preferred over HTML because it allows you to create a dynamic website with loads of options. A PHP-based community website, for instance, will serve unique content to each user even though the URL will stay the same. By contrast, HTML websites are static and the page content can be modified only manually. Like any other software program, PHP has different versions and the one that was used whilst setting up a certain website must be available on the web server in order for the site to run properly.

PHP 4, PHP 5 and PHP 7 Support in Shared Website Hosting

Our shared website hosting servers support several PHP versions, which suggests that your websites will run correctly no matter if your scripts are outdated. We acknowledge the fact that an old website doesn’t inevitably suggest an insecure one as you may have carried out lots of mods to its code. That is the reason why we support PHP 4, PHP 5 and PHP 7 and you can decide which version will be enabled for your web hosting account. You can change the version with a single click of the mouse inside your Hepsia Control Panel and the new settings will take effect straight away. If you want to run both older and newer scripts, there is even a possibility to use a different version of PHP for each of your domains simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

Our Linux semi-dedicated plans support multiple PHP versions, which means that you’ll be able to run all the web apps that you have set up over the years. The Hepsia hosting Control Panel, which comes with each semi-dedicated account, will allow you to activate the version that you need with one single click. You can pick between PHP 4, PHP 5 and PHP 7. If you would like to host multiple sites under the exact same account and they have special requirements connected with the web hosting platform, you will be able to pick a different version for each one of them regardless of which version is enabled for the account itself. This is achievable thanks to our custom-created cloud web hosting platform, which permits us to run several PHP versions concurrently. By comparison, the majority of hosting vendors usually offer one, rarely two versions.